Delays in new mentions processing
Incident Report for YouScan
Resolved
This incident has been resolved.
Posted Oct 21, 2022 - 16:46 EEST
Investigating
We are currently investigating this issue.
Posted Oct 21, 2022 - 16:24 EEST
This incident affected: YouScan.